ESP32 Cam Gesichtserkennung mit MQTT für IoBroker

  • Bei mir verliert er immer die MQTT Verbindung mein signal ist bei -79.

    Versucht er es nicht immer wieder MQTT zu verbinden?


    Und man sollte die Kamera echt eher mit 5V versorgen, hatte auch den fehler am PC USB.


    Im Flash Script steht was mit Postman Echo,

    Code
    1. const char* get_url = "http://postman-echo.com/get?foo="; // Location to send data

    ist das wo er die Geischtstuktur speichert?

    Wenn ja gibt es auch eine lokale Lösung z.b. mit SD Karte in der Kamera?

  • Hey, ich bekomme beim flashen leider immer diesen Fehler:


    Fehler beim Herunterladen von https://www.elzershark.com/iobroker/package_esp32_index.json

    C:\Users\ADMIN\AppData\Local\Temp\package_index.json.sig1994248950315947187.tmp -> C:\Program Files (x86)\Arduino\portable\package_index.json.sig

    Der Sketch verwendet 2186191 Bytes (83%) des Programmspeicherplatzes. Das Maximum sind 2621440 Bytes.

    Globale Variablen verwenden 45408 Bytes (13%) des dynamischen Speichers, 282272 Bytes für lokale Variablen verbleiben. Das Maximum sind 327680 Bytes.

    esptool.py v2.6

    Serial port COM3

    Connecting........_____....._____....._____....._____....._____....._____....._____


    A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header

    A fatal error occurred: Failed to connect to ESP32: Timed out waiting for packet header


    Was soll ich tun?


    Edit: Ich konnte das Problem lösen, indem ich das Kabel an 5V an der Kamera geschlossen habe :)

  • Hallo Elzershark


    Bekomme leider die Krise mit dem Projekt. Ich habe 3 ESP32 Cams hier liegen. Auf allen das gleiche Problem:


    CameraWebServer läuft auf allen 3 ohne Probleme.

    Dein Sketch lässt sich einwandfrei aufspielen. Im Iobroker sehe ich im MQTT Adapter unter Connection die ESPCam, nachdem ich das Webinterface des ESP aufrufe. Allerdings werden die Topics nicht angelegt. Nach gefühlt 20 mal Resetten, funktioniert es sporadisch, allerdings nur das Topic Browser. Auf die Eingabe "1", "on" oder "true" passiert nichts. Kein "Zugriff".


    Eingestellt in Arduino habe ich das ESP Wrover, im Sketch die AI Tinker Camera. Sonst die Daten wie in Deinem Video.


    Irgendein Tip?


    Grüße, Martin

  • ups.. gehts jetzt?